Tuesday, July 9, 2013

Edgewater Switch: Voice (VoIP)/Data Configuration Example

Ok, first and foremost, the ONLY reason I did this was because another services company asked me to put these in for them.  This is an Edgewater switch configuration I did for a company that was doing both voice and data in a converged network.  I have the datasheet on this switch (called a EdgeConnect 2402).  Its backplane speed is 8.8 Gig throughput.  This is terrible considering the Brocade 6430, which is the cheapest, lowest performing switch Brocade has, has a backplane throughput of 56 Gig.  The cheapest Cisco 2960 performs at 32 Gig.  I remember I had to take out the core Edgewater switch because it just couldnt take the load on the network.  I tried to console into the switch and it wouldnt respond.  I had to put a Cisco switch I had in place.  Anyway, you get the idea.
So, back to the config.  This is a layer 2 switch for both voice and data.  Interesting that the CLI is a lot like Cisco in some ways. 

sh run
building running-config, please wait...
!<stackingDB>00</stackingDB>
!<stackingMac>01_70-72-cf-04-cb-80_00</stackingMac>

phymap 70-72-cf-04-af-80
!
hostname SW0
sntp server 64.90.182.55 208.66.175.36 69.25.96.13
!
sntp client
sntp poll 3600
clock timezone UTC hour 6 minute 0 before-utc
!
!
snmp-server location "Main Rack"
!
clock timezone-predefined GMT-0600-Central-Time(US&Canada)
!
snmp-server community public ro
snmp-server community private rw
!
!
username admin access-level 15
username admin password 7 XXXXXXXXXXXX
!
vlan database
 vlan 1 name DefaultVlan media ethernet
  vlan 4 name Voice media ethernet
 vlan 5 name Data media ethernet
 vlan 4093 name Cluster-Vlan media ethernet
!
spanning-tree mst configuration
!
!
ip dhcp snooping information option remote-id mac-address

interface vlan 1
 ip address 192.168.8.20 255.255.255.0
interface vlan 4
interface vlan 5
interface vlan 4093
!
!
interface ethernet 1/1
 switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
 switchport native vlan 5
 switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 !
interface ethernet 1/2
 switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
 switchport native vlan 5
 switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
!
interface ethernet 1/3
 switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
 switchport native vlan 5
 switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
!
interface ethernet 1/4
 switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
 switchport native vlan 5
  switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
!
interface ethernet 1/5
 switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
 switchport native vlan 5
 switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
!
interface ethernet 1/6
 switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
 switchport native vlan 5
 switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
!
 interface ethernet 1/7
 switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
 switchport native vlan 5
 switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
!
interface ethernet 1/8
 switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
 switchport native vlan 5
 switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
!
interface ethernet 1/9
 switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
 switchport native vlan 5
 switchport allowed vlan remove 1
  switchport allowed vlan add 4 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
!
interface ethernet 1/10
 switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
 switchport native vlan 5
 switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
!
interface ethernet 1/11
 switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
 switchport native vlan 5
 switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
!
interface ethernet 1/12
  switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
 switchport native vlan 5
 switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
!
interface ethernet 1/13
 switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
 switchport native vlan 5
 switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
!
interface ethernet 1/14
 switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
 switchport native vlan 5
 switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
  switchport voice vlan auto
 switchport voice vlan rule lldp
!
interface ethernet 1/15
 switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
 switchport native vlan 5
 switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
!
interface ethernet 1/16
 switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
 switchport native vlan 5
 switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
!
interface ethernet 1/17
 switchport allowed vlan add 5 untagged
  no switchport ingress-filtering
 switchport native vlan 5
 switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
!
interface ethernet 1/18
 switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
 switchport native vlan 5
 switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
!
interface ethernet 1/19
 switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
 switchport native vlan 5
 switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
  switchport voice vlan rule lldp
!
interface ethernet 1/20
 switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
 switchport native vlan 5
 switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
!
interface ethernet 1/21
 switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
 switchport native vlan 5
 switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
!
interface ethernet 1/22
 switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
  switchport native vlan 5
 switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
!
interface ethernet 1/23
 switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
 switchport native vlan 5
 switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
!
interface ethernet 1/24
 switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
 switchport native vlan 5
 switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 !
interface ethernet 1/25
 switchport allowed vlan add 5 untagged
 no switchport ingress-filtering
 switchport native vlan 5
 switchport allowed vlan remove 1
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
!
interface ethernet 1/26
 switchport allowed vlan add 1,5 untagged
 no switchport ingress-filtering
 switchport allowed vlan add 4 tagged
 switchport voice vlan auto
!
interface ethernet 1/27
 media-type copper-forced
 switchport allowed vlan add 1 untagged
 no switchport ingress-filtering
 switchport allowed vlan add 1,4-5 tagged
 switchport mode trunk
 switchport voice vlan auto
!
 interface ethernet 1/28
 media-type copper-forced
 switchport allowed vlan add 1 untagged
 no switchport ingress-filtering
 switchport allowed vlan add 1,4-5 tagged
 switchport mode trunk
 switchport voice vlan auto
!
ip default-gateway  192.168.8.2
!
voice vlan 1
voice vlan mac-address 00-AA-DD-82-5F-94 mask FF-FF-FF-00-00-00
!
!
line console
 silent-time 0
!
!
line VTY
!
!
end
!
Console#

No comments:

Post a Comment

Your comment will be reviewed for approval. Thank you for submitting your comments.