Monday, April 13, 2015

Cisco CUBE: ATT SIP To Cisco Cube Router Configuration Example

One thing I have noticed is that working on a SIP config for an AT&T SIP trunk is not the same as most other providers.  In fact, its been really hard to even find a config out there to look at.  All I could find is the several hundred pages of an AT&T document.  So Im pasting my router config here in the hopes this helps someone looking for an AT&T SIP config for their CUBE.  See below.  I hope its helpful.
One thing to note is that in the dial-peers, you do not have to point to the AT&T media servers.  You only have to point your dial-peers to the SIP proxy servers.

======== Cisco CUBE config for AT&T SIP trunk ========
CUBE#sh run
Building configuration...


Current configuration : 9877 bytes
!
! Last configuration change at 23:16:45 CDT Thu Apr 2 2015 by admin
version 15.2
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
service sequence-numbers
!
hostname CUBE
!
boot-start-marker
boot-end-marker
!
!
no logging queue-limit
logging buffered 1000000
no logging rate-limit
no logging console
no logging monitor
!
no aaa new-model
clock timezone CST -6 0
clock summer-time CDT recurring
!
ip cef
!
!
ip dhcp excluded-address 10.10.10.1
!
!
!
ip domain name company.com
no ipv6 cef
!
multilink bundle-name authenticated
!
!
voice-card 0
 dspfarm
 dsp services dspfarm
!
!
voice service voip
 address-hiding
 mode border-element
 allow-connections sip to sip
 no supplementary-service sip moved-temporarily
 redirect ip2ip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
 sip
  bind control source-interface GigabitEthernet0/0
  error-passthru
  asserted-id pai
  early-offer forced
  midcall-signaling passthru
  privacy-policy passthru
  g729 annexb-all
!
voice class codec 1
 codec preference 1 g729r8 bytes 30
 codec preference 2 g711ulaw
!
voice class sip-profiles 1
 response ANY sip-header Allow-Header modify "UPDATE," ""
 request INVITE sdp-header Audio-Attribute modify "a=ptime:20" "a=ptime:30"
 response ANY sdp-header Audio-Attribute modify "a=ptime:20" "a=ptime:30"
 request REINVITE sdp-header Attribute modify "a=T38FaxFillBitRemoval:0" ""
 request INVITE sdp-header Audio-Attribute add "a=ptime:30"
!
!
voice iec syslog
!
!
voice translation-rule 9
 rule 1 /^9/ //
!
!
voice translation-profile outbound
 translate called 9
!
!
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
!
redundancy
!
ip tftp source-interface GigabitEthernet0/0
ip ssh version 2
!
!
interface Loopback0
 no ip address
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description Local LAN
 ip address 192.168.1.2 255.255.255.0
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description ATT Network
 ip address 12.13.14.10 255.255.255.248
 duplex full
 speed 100
!
interface GigabitEthernet0/2
 description VLAN1
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/2.1
 description VLAN1
 encapsulation dot1Q 1 native
 ip address 192.168.1.3 255.255.255.0
!
!
ip forward-protocol nd
!
no ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip route 12.194.138.0 255.255.255.0 12.13.14.9
!
!
control-plane
!
!
mgcp profile default
!
sccp local GigabitEthernet0/0
sccp ccm 192.168.1.13 identifier 2 priority 1 version 7.0
sccp ccm 192.168.1.12 identifier 1 priority 2 version 7.0
sccp
!
sccp ccm group 1
 associate ccm 2 priority 1
 associate ccm 1 priority 2
 associate profile 1 register ATNAL-DC-xcode
 associate profile 2 register ATNAL-DC-cfb
!
dspfarm profile 1 transcode
 description DC Xcoder
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 maximum sessions 20
 associate application SCCP
!
dspfarm profile 2 conference
 description DC conference bridge
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec g729r8
 codec g729br8
 maximum sessions 20
 associate application SCCP
!
dial-peer voice 1 voip
 description Incoming 10-digit calls from AT&T - Facing CUBE for destination
 session protocol sipv2
 incoming called-number [2-9]..[2-9]......$
 voice-class codec 1
 voice-class sip asymmetric payload full
 voice-class sip asserted-id pai
 voice-class sip profiles 1
 voice-class sip bind control source-interface GigabitEthernet0/1
 voice-class sip bind media source-interface GigabitEthernet0/1
 dtmf-relay rtp-nte
 fax-relay sg3-to-g3
 fax rate 14400 bytes 48
 fax protocol t38 version 0 ls-redundancy 5 hs-redundancy 1 fallback none
 no vad
!
dial-peer voice 2 voip
 description Incoming Peer for Outbound calls to AT&T - Facing CUBE for desti
 session protocol sipv2
 incoming called-number 9T
 voice-class codec 1
 voice-class sip asymmetric payload full
 voice-class sip asserted-id pai
 voice-class sip privacy-policy passthru
 voice-class sip profiles 1
 voice-class sip bind control source-interface GigabitEthernet0/0
 voice-class sip bind media source-interface GigabitEthernet0/0
 dtmf-relay rtp-nte
 fax-relay sg3-to-g3
 fax rate 14400 bytes 48
 fax protocol t38 version 0 ls-redundancy 5 hs-redundancy 1 fallback none
 no vad
!
dial-peer voice 12 voip
 description Destination of 10-digit calls from AT&T - Facing CUCM Publisher
 destination-pattern [2-9]..[2-9]......$
 session protocol sipv2
 session target ipv4:192.168.1.12
 voice-class codec 1
 voice-class sip asymmetric payload full
 voice-class sip asserted-id pai
 voice-class sip privacy-policy passthru
 voice-class sip profiles 1
 voice-class sip bind control source-interface GigabitEthernet0/0
 voice-class sip bind media source-interface GigabitEthernet0/0
 dtmf-relay rtp-nte
 fax-relay sg3-to-g3
 fax rate 14400 bytes 48
 fax protocol t38 version 0 ls-redundancy 5 hs-redundancy 1 fallback none
 no vad
!
dial-peer voice 13 voip
 description Destination of 10-digit calls from AT&T - Facing CUCM Subscriber
 destination-pattern [2-9]..[2-9]......$
 session protocol sipv2
 session target ipv4:192.168.1.13
 voice-class codec 1
 voice-class sip asymmetric payload full
 voice-class sip asserted-id pai
 voice-class sip privacy-policy passthru
 voice-class sip profiles 1
 voice-class sip bind control source-interface GigabitEthernet0/0
 voice-class sip bind media source-interface GigabitEthernet0/0
 dtmf-relay rtp-nte
 fax-relay sg3-to-g3
 fax rate 14400 bytes 48
 fax protocol t38 version 0 ls-redundancy 5 hs-redundancy 1 fallback none
 no vad
!
dial-peer voice 20 voip
 description Outgoing calls to AT&T - Facing AT&T Network for Call Setup
 translation-profile outgoing outbound
 destination-pattern 9T
 session protocol sipv2
 session target ipv4:12.194.138.181         <----------- AT&T SIP Proxy
 voice-class codec 1
 voice-class sip asymmetric payload full
 voice-class sip asserted-id pai
 voice-class sip privacy-policy passthru
 voice-class sip profiles 1
 voice-class sip bind control source-interface GigabitEthernet0/1
 voice-class sip bind media source-interface GigabitEthernet0/1
 dtmf-relay rtp-nte
 fax-relay sg3-to-g3
 fax rate 14400 bytes 48
 fax protocol t38 version 0 ls-redundancy 5 hs-redundancy 1 fallback none
 no vad
!
dial-peer voice 30 voip
 description Outgoing calls to AT&T - Facing AT&T Network for Call Media Stre
 translation-profile outgoing outbound
 destination-pattern 9T
 session protocol sipv2
 session target ipv4:12.194.138.69    <----------- AT&T SIP Proxy
 voice-class codec 1
 voice-class sip asymmetric payload full
 voice-class sip asserted-id pai
 voice-class sip privacy-policy passthru
 voice-class sip profiles 1
 voice-class sip bind control source-interface GigabitEthernet0/1
 voice-class sip bind media source-interface GigabitEthernet0/1
 dtmf-relay rtp-nte
 fax-relay sg3-to-g3
 fax rate 14400 bytes 48
 fax protocol t38 version 0 ls-redundancy 5 hs-redundancy 1 fallback none
 no vad
!
!
sip-ua
!
!
!
gatekeeper
 shutdown
!
!
!
scheduler allocate 20000 1000
ntp server us.pool.ntp.org
!
end

CUBE#term len 24
CUBE#

8 comments:

  1. Wow...great post!! I have not worked with any SIP trunks as yet. After reading your post, I'm not sure I want too!!

    ReplyDelete
    Replies
    1. Thanks Brad. AT&T was not alot of help, but I'm hoping this will be helpful to folks.

      Delete
  2. Shane, you are a life saver with this. Thank you very much! You need a paypal account for tips!

    ReplyDelete
  3. Shane thanks for the config specific to AT&T (I am building a libary of them to the big carriers). NO SIP UA configuration? Did you remove them for secrecy or are you using IP Peering? Peering is what many carriers prefer, but given IP Spoofing I see it as a major security hole. Thanks again.

    ReplyDelete
    Replies
    1. No SIP UA commands. I'm sure I didn't do more than what's in the config. After all, I struggled through that myself without having a good understanding of what I was doing at the time. AT&T wouldn't help me much and I was going at it alone. What you see in the config was all there was.

      Delete
  4. This is a great read.. thank you. I'm wondering if we made some changes to our CUBE, maybe we would resolve some one way audio problems we are experiencing.

    ReplyDelete
  5. Hey Shane, I recognize some of this configuration. Long time ago.

    Thomas W.

    ReplyDelete

Your comment will be reviewed for approval. Thank you for submitting your comments.