One difference is that I have multiple connections to each device. So I will have multiple ports on each device for the single virtual port-channel in this case.
Also note: I have confirmed that the domain ID for the 7Ks has to be a different ID number than on the 5Ks. So, in my case, the 7Ks have a domain ID of 10. My 5Ks have a domain ID of 5.
Here is the config template I wrote up to get this going:
On each 7K:
interface port-channel50
description vPC50-7k-5k
switchport
switchport mode trunk
speed 10000
vpc 50
interface Ethernet3/5
description *** To 5K-5 ***
switchport mode trunk
speed 10000
channel-group 50 mode active
no shutdown
interface Ethernet4/5
description *** To 5K-5 ***
switchport mode trunk
speed 10000
channel-group 50 mode active
no shutdown
interface Ethernet3/6
description *** To 5K-6 ***
switchport mode trunk
speed 10000
channel-group 50 mode active
no shutdown
interface Ethernet4/6
description *** To 5K-6 ***
switchport mode trunk
speed 10000
channel-group 50 mode active
no shutdown
On each 5K:
interface port-channel50
description vPC50-7k-5k
switchport
switchport mode trunk
speed 10000
vpc 50
interface Ethernet1/7
description *** To 7K-1 ***
switchport mode trunk
speed 10000
channel-group 50 mode active
no shutdown
interface Ethernet1/8
description *** To 7K-1 ***
switchport mode trunk
speed 10000
channel-group 50 mode active
no shutdown
interface Ethernet1/9
description *** To 7K-2 ***
switchport mode trunk
speed 10000
channel-group 50 mode active
no shutdown
interface Ethernet1/10
description *** To 7K-2 ***
switchport mode trunk
speed 10000
channel-group 50 mode active
no shutdown
interface port-channel50
description vPC50-7k-5k
switchport
switchport mode trunk
speed 10000
vpc 50
interface Ethernet3/5
description *** To 5K-5 ***
switchport mode trunk
speed 10000
channel-group 50 mode active
no shutdown
interface Ethernet4/5
description *** To 5K-5 ***
switchport mode trunk
speed 10000
channel-group 50 mode active
no shutdown
interface Ethernet3/6
description *** To 5K-6 ***
switchport mode trunk
speed 10000
channel-group 50 mode active
no shutdown
interface Ethernet4/6
description *** To 5K-6 ***
switchport mode trunk
speed 10000
channel-group 50 mode active
no shutdown
On each 5K:
interface port-channel50
description vPC50-7k-5k
switchport
switchport mode trunk
speed 10000
vpc 50
interface Ethernet1/7
description *** To 7K-1 ***
switchport mode trunk
speed 10000
channel-group 50 mode active
no shutdown
interface Ethernet1/8
description *** To 7K-1 ***
switchport mode trunk
speed 10000
channel-group 50 mode active
no shutdown
interface Ethernet1/9
description *** To 7K-2 ***
switchport mode trunk
speed 10000
channel-group 50 mode active
no shutdown
interface Ethernet1/10
description *** To 7K-2 ***
switchport mode trunk
speed 10000
channel-group 50 mode active
no shutdown
Can you post your full config. It would be really helpful.
ReplyDeleteThanks for your post. Would this work if the top switches were 9Ks instead of 7Ks?
ReplyDeleteCheers!
I would think so, let me get my hands on some 9ks and I'll check it. Give me some time on it.
Delete