Well, Im not sure this is really worth posting about. But I have had to do several route-maps lately on a Cisco Nexus 7K. Its really the same (except for the ACL) as a Catalyst switch. Nothing really different, but below is an example config that might help you out.
ip access-list 107
deny ip 192.168.0.0 0.0.255.255 4.4.4.0 0.0.0.255
deny ip 192.168.0.0 0.0.255.255 5.0.0.0 0.255.255.255
deny ip 192.168.0.0 0.0.255.255 33.33.0.0 0.0.255.255
deny ip 192.168.0.0 0.0.255.255 66.66.0.0 0.0.255.255
permit tcp 192.168.0.0 0.0.255.255 any
permit ip 192.168.0.0 0.0.255.255 any
deny ip any any
route-map Public_WIFI permit 10
match ip address 107
set ip next-hop 192.168.70.55
interface ethernet 7/15
ip policy route-map Public_WIFI
This is the retired Shane Killen personal blog, an IT technical blog about configs and topics related to the Network and Security Engineer working with Cisco, Brocade, Check Point, and Palo Alto and Sonicwall. I hope this blog serves you well. -- May The Lord bless you and keep you. May He shine His face upon you, and bring you peace.
Subscribe to:
Post Comments (Atom)
Hi Shane...so, is route-maps and policy-based-routing (PBR) the same thing? Or is there a difference? Just wondering if I've missed something or not. Thanks...
ReplyDeleteHey Brad. PBR is the general term used for manipulating traffic, but route maps are the "means" of manipulating the traffic. Route maps use ACLs and you apply them to an interface. Kind of like painting a house. You tell people you got your house painted, but you used a paint brush and paint to do it. Same with PBR. You did PBR, but you used route maps and ACLs to accomplish it.
DeleteThanks Shane! Good clarification!!
ReplyDelete