GigabitEthernet1/2/2 is up, line protocol is down (LACP-BLOCKED)
I saw this last night when trying to connect a Cisco switch configured for a port-channel to a Brocade ICX7450 LAG. Keep in mind, a LAG and Port-channel are the same thing, which is bonded ports for more throughput and redundancy. In this case, we were using LACP.
Config for a Brocade LACP LAG in version 8.X:
lag LAG01 dynamic id 1
ports ethernet 1/2/2 ethernet 1/2/4
primary-port 1/2/2
port-name ***ToCisco*** ethernet 1/2/2
deploy
Because I was getting the error message above, I asked the other engineer if they had their side configured for LACP. She said yes, but then she double checked and verified that she actually didn't have either "mode active" or "mode passive" with the "channel-group 1" command. She actually had "mode auto", which uses port aggregation protocol (PagP) instead. Simple mistake that we all make at some point. She corrected and then the LAG came up and we started passing traffic.
Below is what I saw when I did a "show lag" on the Brocade side"
DIR_Irondale_(config)#sh lag
Total number of LAGs: 1
Total number of deployed LAGs: 1
Total number of trunks created:1 (255 available)
LACP System Priority / ID: 1 / 609c.9f3a.a488
LACP Long timeout: 120, default: 120
LACP Short timeout: 3, default: 3
=== LAG "LAG01" ID 1 (dynamic Deployed) ===
LAG Configuration:
Ports: e 1/2/2 e 1/2/4
Port Count: 2
Primary Port: 1/2/2
Trunk Type: hash-based
LACP Key: 20001
Deployment: HW Trunk ID 1
Port Link State Dupl Speed Trunk Tag Pvid Pri MAC Name
1/2/2 Up Blocked Full 1G 1 Yes 18 0 609c.9f3a.a488 ***ToCisco***
1/2/4 Up Blocked Full 1G 1 Yes 18 0 609c.9f3a.a488
Port [Sys P] [Port P] [ Key ] [Act][Tio][Agg][Syn][Col][Dis][Def][Exp][Ope]
1/2/2 1 1 20001 Yes S Agg Syn Col Dis Def No Ina
1/2/4 1 1 20001 Yes S Agg Syn No No Def No Ina
...
Just know that if you get the above message (GigabitEthernet x/x/x is up, line protocol is down (LACP-BLOCKED), you have a LAG protocol mismatch.
Beautiful, had this head scratcher today and had totally missed the fact 'laggproto lacp' wasn't set on the client-side BSD lagg0 port, meaning I had a mis-match. Many thanks for this post!
ReplyDeleteHi , Just want share below command , which i used to create LAG/LACP on brocade and cisco
ReplyDeleteFor Cisco
---------------------------------------------------------------------------------
Cisco IOS Port Channel/LAG Configuration
Cisco(config)# interface port-channel 1
Cisco(config-if)# switchport trunk encapsulation dot1q
Cisco(config-if)# switchport trunk allowed vlan All
Cisco(config-if)# switchport mode trunk
Cisco(config-if)# switchport nonegotiate
Cisco(config)# interface range g1/0/1 - 2
Cisco(config-if-range)# switchport trunk encapsulation dot1q
Cisco(config-if-range)# switchport trunk allowed vlan All
Cisco(config-if-range)# switchport mode trunk
Cisco(config-if-range)# switchport nonegotiate
Cisco(config-if-range)# channel-group 1 mode active
********************************************
Cisco# show lacp 1 internal
Cisco# show interfaces etherchannel
---------------------------------------------------------------------------------------------------
For Brocade
---------------------------------------------------------------------------------------------------
Brocade ICX LAG Configuration
Brocade(config)# lag brocade dynamic id 11
Brocade(config-lag-brocade)# ports ethernet 1/2/1 ethernet 1/2/2
-----------------------------------------------------------------------------------------------
Hope is this informative for you.